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2
แผนที่แสดงตำแหน่งแหล่งศิลปะบนหิน



โครงการสำรวจด้วยภาพถ่ายแหล่งศิลปะบนหิน จังหวัดพิษณุโลก
มีเป้าหมายเพื่อบันทึกและศึกษาแหล่งศิลปะบนหิน ได้แก่ 
แหล่งภาพเขียนสีและแหล่งภาพสลัก ด้วยการบันทึกถ่ายภาพ
ลวดลายที่ปรากฏบนผนังหินในพื้นที่สำรวจ ซึ่งงานศิลปะเหล่านี้เป็น
หลักฐานทางวัฒนธรรมที่สำคัญของมนุษย์ในอดีต 

พ.ศ.2567 เป็นปีแรกในการดำเนินโครงการ ได้มีความพยายามใน
การพัฒนาเทคนิควิธีการ ในการบันทีกข้อมูลแหล่งศิลปะบนหิน
โดยประยุกต์ใช้ระบบภูมิสารสนเทศและการสำรวจด้วยภาพถ่ายมา
ช่วยในการศึกษาวิจัยแหล่งศิลปะบนหิน ผลจากการดำเนินงาน
พบว่าเทคนิคและวิธีการที่ใช้ช่วยให้การเก็บบันทึกข้อมูลภาคสนามมี
ความครบถ้วนและแม่นยำมากขึ้น ทั้งในด้านตำแหน่ง ขนาด และ
รายละเอียดของลวดลายศิลปะ 

จากประสบการณ์การทำงานภาคสนามและการวิเคราะห์ในห้อง
ปฏิบัติการ เห็นว่าการถอดบทเรียน และเรียบเรียงองค์ความรู้ เกี่ยว
กับการสำรวจและบันทึกข้อมูลแหล่งศิลปะบนหิน จะช่วยสะท้อน
แนวทางการศึกษาที่เป็นระบบและทันสมัย สามารถนำไปใช้เป็น
แนวทางในการวิจัยและอนุรักษ์แหล่งศิลปะบนหินต่อไป

กลุ่มโบราณคดี สำนักศิลปากรที่ 6 สุโขทัย
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5
แผนที่แสดงตำแหน่งแหล่งศิลปะบนหิน



องค์ความรู้ ชุดนี้ มีวัตถุประสงค์เพื่อรวบรวม
ข้อมูลเทคนิควิธีการในการบันทึกข้อมูลแหล่ง
ศิลปะบนหิน ซึ่งเป็นการถอดบทเรียนจากการ
ปฏิบัติงานภาคสนามและห้องปฏิบัติการ ซึ่งได้
ดำเนินการภายใต้โครงการสำรวจด้วยภาพถ่าย
แหล่งศิลปะบนหิน จังหวัดพิษณุโลก พุทธศักราช
2567 

จากการปฏิบัติงานภาคสนาม เริ่มตั้งแต่ระหว่าง
เดือนตุลาคม 2565 ถึง เดือนกันยายน 2567
ได้ดำเนินการสำรวจแหล่งศิลปะบนหินในจังหวัด
พิษณุโลก จำนวน 8 แห่ง ได้แก่ ถ้ำกาเล็ก ถ้ำกา-
ใหญ่ ผากระดานเลข ผาขีดบางยาง ผาขีดภูขัด
ผาบ่อง ผาสบแลน หินสามพี่น้อง ซึ่งได้นำวิธีการ
สำรวจด้วยภาพถ่ายมาใช้ในการบันทึกข้อมูล
แหล่งศิลปะบนหิน ทำให้พบว่าการบันทึกข้อมูลมี
ความถูกต้องแม่นยำมากขึ้น ช่วยให้การวิเคราะห์
ข้อมูลรูปแบบศิลปะบนหินได้ครบถ้วน จึงได้
ทบทวนถอดบทเรียนจากการปฏิบัติงานมานำ
เสนอในครั้งนี้ 

ด้วยเห็นว่าจะเป็นประโยชน์ต่อวงการศึกษา
โบราณคดีและศิลปะบนหินในประเทศไทย กระตุ้น
ให้มีการถกเถียงในทางวิชาการ เพื่อการ
สร้างสรรค์และพัฒนาองค์ความรู้ ในการศึกษา
ศิลปะบนหินในประเทศไทยมากขึ้น

องค์ความรู้ ชุดนี้ แบ่งได้เป็น 4 ส่วน ดังนี้
1. แนะนำศิลปะบนหิน
2. การจัดทำแผนที่และแบบฟอร์มสำรวจด้วย
ระบบภูมิสารสนเทศ
3. การสำรวจด้วยภาพถ่าย
4. การคัดลอกงานศิลปะบนหิน

คำแนะนำ
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การใช้งานองค์ความรู้ ชุดนี้ เริ่มจากองค์ความรู้
ชุดที่ 1 การแนะนำข้อมูลความรู้ พื้นฐานต่าง ๆ
นิยาม ความหมายของศิลปะบนหิน เทคนิควิธี
การสร้างงานศิลปะ ประวัติการศึกษาแหล่งศิลปะ
บนหิน ขั้นตอนวิธีการศึกษา ซึ่งเป็นข้อมูลโดย
สังเขป 

จากนั้นเข้าสู่เนื้อหาองค์ความรู้ ชุดที่ 2 การจัดทำ
แผนที่ฐาน อธิบายเกี่ยวกับขั้นตอนการเตรียม
การในสำรวจ การเตรียมข้อมูลที่เกี่ยวข้องกับ
พื้นที่ศึกษา การสร้างแผนที่ แบบฟอร์ม ด้วย
ระบบภูมิสารสนเทศ สำหรับใช้ในการสำรวจภาค
สนาม

เมื่อเตรียมข้อมูลพร้อมแล้วเข้าสู่เนื้อหาองค์
ความรู้ ชุดที่ 3 การสำรวจภาคสนาม ด้วยวิธีการ
สำรวจด้วยภาพถ่าย ซึ่งเป็นการถ่ายภาพเพื่อ
บันทึกข้อมูลงานศิลปะบนหิน การจดบันทึกข้อมูล
ที่เกี่ยวข้องลงในแบบฟอร์มสำรวจ 

เมื่อได้ข้อมูลจากการสำรวจเรียบร้อยแล้ว จึงเข้า
สู่เนื้อหา องค์ความรู้ ชุดที่ 4 การคัดลอกงาน
ศิลปะบนหิน ซึ่งเป็นกระบวนการวิเคราะห์ภาพใน
ห้องปฏิบัติการ (คอมพิวเตอร์) ประมวลผลภาพ
และคัดลอกภาพด้วยซอฟต์แวร์ภูมิสารสนเทศ
และจัดจำแนกรูปแบบของภาพต่อไป



บทนำ

องค์ความรู้ แหล่งศิลปะบนหิน เรื่องที่ 2
การสร้างแผนที่และแบบฟอร์มสำรวจด้วย
ระบบภูมิสารสนเทศ จะเป็นการอธิบายถึง
วิธีการขั้นตอนในการจัดทำแผนที่ฐานและ
แบบฟอร์มสำหรับการสำรวจเก็บบันทึก
ข้อมูลแหล่งศิลปะบนหิน ซึ่งก่อนที่จะเข้าสู่
เนื้อหาขั้นตอนการปฏิบัติงานในห้องปฏิบัติ
การ (คอมพิวเตอร์) เราจำเป็นต้อง
ทำความเข้าใจพื้นฐานแนวคิดในการศึกษา
เบื้องต้นว่ามีที่มาอย่างไร
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การใช้ระบบภูมิสารสนเทศทางโบราณคดี
นั้น สืบเนื่องมาจากคำถามพื้นฐานที่นัก
โบราณคดีต้องการทราบว่า มนุษย์ในอดีต
ทำอะไร ที่ไหน อย่างไร โดยคำสำคัญว่าที่
ไหน เป็นคำถามที่นักโบราณคดีต้องการหา
คำตอบเกี่ยวกับพื้นที่



การศึกษาพื้นที่ในมุมมองของนัก
โบราณคดีนั้น จำเป็นต้องพึงพาอาศัย
ความรู้ จากวิชาอื่น ๆ เช่น ธรณีวิทยา (หิน
และแร่) ปฐพีวิทยา (ดิน) ภูมิศาสตร์
(ภูมิประเทศ) เป็นต้น ซึ่งเป็นวิชาที่เกี่ยว
กับการศึกษารูปร่าง ลักษณะทางกายภาพ
ความสูงต่ำ และประวัติธรรมชาติของพื้นที่
ว่าเกิดขึ้นได้อย่างไร ปัจจัยที่ส่งผลให้เกิด
ภูมิประเทศแบบต่าง ๆ 

นักธรณีวิทยาอธิบายว่ามีแกนโลกและชั้น
หินที่รองรับแผ่นเปลือกโลก การเคลื่อนตัว
ของแผ่นเปลือกโลกทำให้พื้นผิวโลกเกิด
เป็นภูมิประเทศที่มีความสูงต่ำรูปร่างแตก
ต่างกัน เช่น พื้นทะเล ภูเขา ที่ราบ แอ่งน้ำ
เป็นต้น ส่วนหินก็มีหลายชนิด เช่น
หินทราย หินปูน หินอัคนี เป็นต้น หินเหล่า
นี้เมื่อผ่านเวลาจะผุกร่อนเป็นตะกอนถูก
พัดพาไปสะสมตัวในที่ราบลุ่มรวมกันเป็น
ดิน

นักปฐพีวิทยาจึงได้ศึกษาดินและแบ่ง
ประเภทดินเป็นกลุ่มชุดดินต่าง ๆ ซึ่งมี
คุณสมบัติทางกายภาพที่หลากหลาย เช่น
การระบายของน้ำ เนื้อดิน แร่ธาตุ เป็นต้น

เมื่อมีมนุษย์เข้าไปใช้พื้นที่ จึงเป็นหน้าที่
ของนักโบราณคดีที่จะอธิบายว่าเกิด
กิจกรรมอะไรขึ้นบ้างบริเวณนั้น ทั้งในแนว
ระนาบตั้งแต่แหล่งถึงภูมิภาคและแนวดิ่ง
จากผิวดินลงไปถึงชั้นดินธรรมชาติที่ไม่
ปรากฏร่องรอยกิจกรรมของมนุษย์
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นักโบราณคดีจะอาศัยความรู้ จากวิชาเหล่า
นั้น มาช่วยอธิบายว่ามนุษย์ในอดีตได้
เข้าไปทำอะไรในพื้นที่ตรงนั้น โดยอาศัย
ข้อมูลภาพรวมของพื้นที่ เพื่อหาคำตอบว่า
มนุษย์มีแนวคิดหรือพฤติกรรมในการใช้
พื้นที่อย่างไร มีการปรับตัวเข้ากับ
ภูมิประเทศ มีการดัดแปลง เปลี่ยนแปลง
สภาพทางกายภาพ เช่น การไถพรวน การ
ขุดคูน้ำ การก่อสร้างคันดินกำแพงเมือง
การทำเหมือง เป็นต้น 

ในช่วงทศวรรษที่ 1980 มีนักโบราณคดี
กลุ่มหนึ่งเสนอแนวคิดโบราณคดีเชิงพื้นที่
ขึ้นมา เพื่อศึกษาความสัมพันธ์ระหว่าง
พื้นที่กับแบบแผนกิจกรรมที่มนุษย์ในอดีต
ทำขึ้นในพื้นที่นั้ น ๆ โดยเครื่องมือที่นัก
โบราณคดีนำมาใช้ช่วยในการเก็บบันทึก
ข้อมูล คือ ระบบภูมิสารสนเทศ ซึ่งเป็น
ระบบที่ช่วยในการจัดเก็บและจัดการข้อมูล
เชิงพื้นที่ที่มีประสิทธิภาพ และสามารถ
สร้างแผนที่ได้ตามที่ต้องการอีกด้วย

ดังนั้น ในองค์ความรู้ เรื่องนี้ เราจะมา
ทำความรู้ จักกับแนวคิดโบราณคดีเชิง
พื้นที่ (Spatial Archaeology) 
ระบบภูมิสารสนเทศ (Geographic
Information System: GIS) และวิธี
การนำมาใช้ในการสำรวจแหล่งศิลปะบน
หิน ว่ามีขั้ นตอนการปฏิบัติอย่างไร เริ่ม
ตั้งแต่การสร้างแผนที่และแบบฟอร์ม
สำหรับการสำรวจภาคสนาม



โบราณคดีเชิงพื้นที่

Clarke (1977) เสนอว่า โบราณคดีเชิงพื้นที่ คือ การศึกษาทางโบราณคดีที่เกี่ยวข้องกับ
ข้อมูลเชิงพื้นที่มีเป้าหมายเพื่อวิเคราะห์ความสัมพันธ์ระหว่างแบบแผนกิจกรรม ร่องรอย
กิจกรรม และโครงสร้างภายในแหล่งโบราณคดี เพื่อตรวจสอบว่ารูปแบบของกิจกรรม
เหล่านี้มีความเชื่อมโยงกับสิ่งแวดล้อมในพื้นที่ศึกษาอย่างไร ตั้งแต่ระดับแหล่งโบราณคดี
ไปจนถึงระดับภูมิภาค

แนวทางการศึกษามุ่งเน้นการวิเคราะห์ความสัมพันธ์และการวัดค่าความแปรปรวนของ
การกระจายตัวในโครงสร้างลำดับขั้น และรูปแบบอื่น ๆ ของโครงสร้างภายในพื้นที่ศึกษา
โดยอาศัยแนวคิดจากหลากหลายศาสตร์ เช่น ภูมิศาสตร์ เศรษฐศาสตร์เชิงพื้นที่
สถาปัตยกรรม มานุษยวิทยา ฟิสิกส์ และสถิติ เพื่อสร้างความเข้าใจเกี่ยวกับการใช้พื้นที่ทำ
กิจกรรมของมนุษย์และชุมชนโบราณ ซึ่งในการประมวลและวิเคราะห์ข้อมูลเหล่านี้ จำเป็น
ต้องใช้ระบบสารสนเทศภูมิศาสตร์มาช่วยในการจัดการข้อมูลนั่นเอง
____
Clarke, D. (Ed.). (1977). Spatial archaeology. New York: Academic Press.
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องค์ประกอบสำคัญ

โบราณวัตถุ: วิเคราะห์ลักษณะ การกระจาย และความสัมพันธ์ของโบราณวัตถุ ในระดับ
แหล่งโบราณคดี เพื่อระบุกิจกรรมในการใช้พื้นที่
วัตถุดิบและแหล่งวัตถุดิบ: ศึกษาการใช้และกระจายตัวของวัตถุดิบที่เกี่ยวข้องกับ
กิจกรรมการผลิตในอดีต ระดับครัวเรือนไปจนถึงระดับชุมชน
สิ่งก่อสร้างและส่วนประกอบ: ศึกษาโครงสร้าง เช่น ที่อยู่อาศัย ศาสนสถาน การวาง
ผังเมือง และโครงสร้างอื่น ๆ เพื่อทำความเข้าใจการใช้พื้นที่ในระดับครัวเรือน ชุมชน
หรือเมือง
เส้นทางคมนาคม: วิเคราะห์เส้นทางที่เชื่อมโยงระหว่างแหล่งโบราณคดีและพื้นที่โดย
รอบในระดับภูมิภาค

10



ระบบสารสนเทศภูมิศาสตร์ 

ระบบสำหรับการจัดการข้อมูลเชิงพื้นที่ และข้อมูลภูมิศาสตร์ มีการพัฒนาขึ้นมาเมื่อต้น
ทศวรรษที่ 1960 โดย Roger Tomlinson (1962) นักภูมิศาสตร์ชาวอังกฤษที่ได้เสนอวิธี
การจัดการข้อมูลภูมิศาสตร์ การจัดทำแผนที่โดยใช้คอมพิวเตอร์ในการจัดเก็บ รวบรวม
และประมวลข้อมูล เช่น ข้อมูลพื้นที่ ธรรมชาติ และเศรษฐกิจ เพื่อใช้ในการวิเคราะห์และ
ประเมินผลการจัดการพื้นที่การเกษตร และเป็นคนแรกที่เสนอคำว่า Geographic
Information System ในการพัฒนาระบบฐานข้อมูล โดยใช้ระบบคอมพิวเตอร์ในการจัด
เก็บข้อมูลสารสนเทศภูมิศาสตร์ สำหรับการวางแผนพัฒนาพื้นที่ และการวางผังเมืองระดับ
ภูมิภาคในประเทศแคนาดา ซึ่งในขณะนั้นได้ใช้ฮาร์ดแวร์ในการจัดเก็บข้อมูล คือ IBM
system 360 model 50 ซึ่งเป็นเมนเฟรมคอมพิวเตอร์ขนาดใหญ่ ที่สามารถเก็บข้อมูล
ได้ปริมาณมากขึ้น และประมวลผลได้อย่างเป็นระบบ ซึ่งจากจุดเริ่มต้นนี้นำไปสู่การพัฒนา
ระบบสารสนเทศภูมิศาสตร์ รวมถึงการพัฒนาของอุปกรณ์ต่าง ๆ ที่เกี่ยวข้องในระบบ
สารสนเทศภูมิศาสตร์ ทำให้มีการใช้อย่างแพร่หลายมากขึ้นในปัจจุบัน
____
R. F. Tomlinson. (1962). “Computer Mapping: An Introduction to the Use of Electronic Computers in the
Storage, Compilation and Assessment of Natural and Economic Data for the Evaluation of Marginal
Lands”, National Land Capability Inventory Seminar, Agricultural Rehabilitation and Development
Administration of the Canada Department of Agriculture, Ottawa, p. 9, Nov. 29-30, 1962.
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ระบบสารสนเทศภูมิศาสตร์ถูกพัฒนาขึ้นมาเพื่อการรวบรวมข้อมูล การจัดเก็บข้อมูล การ
จัดการข้อมูล การวิเคราะห์ข้อมูล รวมถึงการแสดงผลข้อมูล ซึงเป็นข้อมูลเชิงพื้นที่ที่มี
ตำแหน่งอ้างอิงบนผิวโลก (Geospatial data) โดยใช้เทคโนโลยีการรับรู้ ระยะไกล
(Remote sensing) ระบบกำหนดตำแหน่งบนโลก (Global Positioning system หรือ
GPS) และระบบสารสนเทศภูมิศาสตร์ (Geographic Information System) เป็นองค์
ประกอบหลักในการบริหารจัดการข้อมูลเชิงพื้นที่ เพื่อให้ได้เป็นข้อมูลสารสนเทศเชิงพื้นที่
(Geospatial Information) ที่นำไปประกอบการศึกษา การวางแผน การบริการ
สาธารณะ การบริหารเชิงธุรกิจ และการตัดสินใจในการจัดการทรัพยากร และสิ่งแวดล้อม
ได้อย่างเป็นระบบและมีประสิทธิภาพ (สุเพชร จิรขจรกุล, 2552) รวมถึงการประยุกต์ใช้ใน
งานโบราณคดี และการบริหารจัดการทรัพยากรมรดกทางศิลปวัฒนธรรม
____
สุเพชร จิรขจรกุล. (2552). เรียนรู้ ระบบภูมิสารสนเทศด้วยโปรแกรม ArcGIS Desktop 9.3.1. นนทบุรี: บริษัท เอส อาร์
พริ้นติ้ง แมสโปรดักส์ จำกัด.
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องค์ประกอบของ
ระบบสารสนเทศภูมิศาสตร์ 

1. ฮาร์ดแวร์ (Hardware) อุปกรณ์ที่ใช้ในการทำงานของระบบ GIS
2. ซอฟต์แวร์ (Software) โปรแกรมที่ใช้ในการประมวลผลและวิเคราะห์ข้อมูล GIS
3. ข้อมูล (Data) ข้อมูลเป็นองค์ประกอบที่สำคัญที่สุดของระบบ GIS คือ ข้อมูลเชิงพื้นที่
(Spatial Data) 
4. บุคลากร (People) ผู้ที่ใช้งานและดูแลระบบ GIS 
5. กระบวนการ (Procedures) ขั้นตอน วิธีการ และแนวปฏิบัติในการรวบรวม จัดการ
วิเคราะห์ และนำเสนอข้อมูล GIS
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ที่มา: https://chatgpt.com/



ข้อมูลเชิงพื้นที่
(Spatial Data)
ข้อมูลที่แสดงเป็นภาพแบบสองมิติหรือ
สามมิติ ประกอบด้วยข้อมูลกราฟิก และ
ข้อมูลลักษณะประจำ เป็นข้อมูลทาง
กายภาพของวัตถุ แทนค่าด้วยตัวเลขใน
ระบบพิกัดภูมิศาสตร์ แสดงตำแหน่ง
ขนาด และรูปร่างของวัตถุ (สำนักงาน
พัฒนาเทคโนโลยีอวกาศและภูมิ
สารสนเทศ, 2561) เช่น ภูเขา แม่น้ำ
ถนน อาคาร เป็นต้น จำแนกตาม
ลักษณะโครงสร้างข้อมูลแบ่งออกเป็น
2 ประเภท ได้แก่ 🟩 ข้อมูลเวกเตอร์
(Vector Data) 🟫 ข้อมูลแบบแรส
เตอร์ (Raster Data) 

____
สำนักงานพัฒนาเทคโนโลยีอวกาศและภูมิสารสนเทศ. (2561).
อภิธานศัพท์การรับรู้ จากระยะไกล (Remote Sensing
Glossary). กรุงเทพฯ : สำนักงานพัฒนาเทคโนโลยีอวกาศ
และภูมิสารสนเทศ (องค์การมหาชน) กระทรวงวิทยาศาสตร์.

ข้อมูลเชิงบรรยาย
(Attribute Data)
ข้อมูลประกอบที่อธิบายคุณสมบัติของ
ข้อมูลเชิงพื้นที่ เช่น ตารางที่ระบุว่า
แปลงเกษตรแต่ละแปลงปลูกพืชอะไร,
ใครเป็นเจ้าของ, พื้นที่กี่ไร่ หรือ ตารางที่
ระบุว่าแหล่งโบราณคดีแต่ละแห่ง เป็น
แหล่งประเภทใด พบหลักฐานทาง
โบราณคดีอะไรบ้าง เป็นต้น
ข้อมูลเหล่านี้ มักเก็บในรูปแบบตาราง
เช่น .exl, .csv, .dbf, หรือฐานข้อมูล
SQL เป็นต้น

📂รูปแบบข้อมูลในระบบ GIS
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🟩 ข้อมูลเวกเตอร์ (Vector Data) 
ข้อมูลแบบเชิงเส้น เป็นข้อมูลที่ใช้ค่าพิกัด X และ Y เพื่อกำหนดตำแหน่งของจุด เส้น
และรูปหลายเหลี่ยม เช่น ข้อมูลพิกัดของแหล่งศิลปะบนหินที่ระบุค่า ละติจูด / ลองจิจูด
เป็นต้น ประกอบด้วย:

จุด (Point): เช่น ตำแหน่งบ้าน ต้นไม้ บ่อน้ำ เป็นต้น
เส้น (Line): เช่น ถนน แม่น้ำ เส้นทางเดิน เป็นต้น
รูปหลายเหลี่ยม (Polygon): เช่น เขตอำเภอ แปลงนา พื้นที่ป่า ขอบเขตโบราณ
สถาน เป็นต้น

🔹 ไฟล์นามสกุลที่ใช้: .shp (Shapefile), .geojson, .kml, .gdb, .dxf
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🟫 ข้อมูลแรสเตอร์ (Raster Data) 
เมทริกซ์ของเซลล์หรือจุดภาพจัดอยู่ในรูปแถวและสดมภ์ ซึ่งแต่ละเซลล์จะมีค่าของ
ข้อมูล เช่น อุณหภูมิ ค่าการสะท้อน ค่าพลังงาน ความสว่างสี ความสูง เป็นต้น ข้อมูล
แบบแรสเตอร์ ประกอบด้วย:  

ภาพดิจิทัล เช่น ภาพถ่ายดาวเทียม ภาพถ่ายทางอากาศ แผนที่ภูมิประเทศ เป็นต้น
แบบจำลองความสูง 
แบบจำลองพื้นผิว 
แบบจำลองภูมิประเทศ 

🔹 ไฟล์นามสกุลที่ใช้: .tif (GeoTIFF), .jpg, .png, .img



ภาพรวมของอนเทอร์เฟซ QGIS

ก่อนที่เราจะมาเริ่มทำแผนที่โดยใช้ QGIS นั้น สามารถไปดาวโหลดซอฟต์แวร์มาใช้ได้
โดยไม่มีค่าใช้จ่ายได้ที่ https://qgis.org/download/ เมื่อดาวโหลดมาแล้ว ติดตั้ง
ซอฟต์แวร์ให้เรียบร้อยแล้วเปิดซอฟต์แวร์ขึ้นมา เพื่อทำความรู้ จักภาพรวมของ
อินเทอร์เฟซ และเครื่องมือต่าง ๆ ของ QGIS

1. รายการชั้นข้อมูลและแผงเบราว์เซอร์ Layers List / Browser Panel
2. แถบเครื่องมือ Toolbars
3. พื้นที่แสดงแผนที่ Map canvas
4. แถบสถานะ Status bar
5. แถบเครื่องมือด้านข้าง Side Toolbar
6. แถบค้นหา Locator bar

17

🗺️การทำแผนที่ด้วย QGIS

ที่มา: https://docs.qgis.org/3.40/en/docs/training_manual/basic_map/overview.html

https://qgis.org/download/
https://qgis.org/download/
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1.รายการชั้นข้อมูล (Layers list)/ แผงเบราว์เซอร์
(Browser Panel) 

แถบรายการชั้นข้อมูล แสดงรายชื่อของชั้น
ข้อมูลทั้งหมดที่มีให้ใช้งานได้ตลอดเวลา หาก
คุณขยายรายการที่ถูกย่อไว้ (โดยคลิกที่ลูกศร
ข้างๆ รายการ) คุณจะได้รับข้อมูลเพิ่มเติม
เกี่ยวกับลักษณะปัจจุบันของชั้นข้อมูลนั้น เมื่อ
คุณวางเมาส์เหนือชั้นข้อมูล จะมีข้อมูลพื้นฐาน
แสดงขึ้นมา เช่น ชื่อชั้นข้อมูล ระบบพิกัด
อ้างอิง และที่อยู่ของไฟล์บนอุปกรณ์ 
แผงเบราว์เซอร์ คือ แผงควบคุม ในโปรแกรม
QGIS ที่ช่วยให้คุณสามารถเข้าถึงและเรียกดู
ข้อมูลในฐานข้อมูลของคุณได้อย่างสะดวก
ง่ายดาย โดยคุณสามารถเปิดไฟล์เวกเตอร์
ทั่วไป เช่น ESRI Shapefile หรือไฟล์จาก
MapInfo ได้ รวมถึงเข้าถึงฐานข้อมูลต่าง ๆ
เช่น PostGIS, Oracle, SpatiaLite,
GeoPackage หรือ MS SQL Server และยัง
สามารถเชื่อมต่อกับบริการ WMS/WFS ได้อีก
ด้วย นอกจากนี้ยังสามารถดูข้อมูลจาก
GRASS ได้เช่นกัน
ถ้าได้บันทึกโปรเจกต์ไว้แล้ว แผง QGIS
Browser จะแสดงรายการเลเยอร์ทั้งหมดที่
อยู่ในโฟลเดอร์เดียวกับไฟล์โปรเจกต์นั้น
(ไฟล์ .qgs) ภายใต้หัวข้อ Project Home
นอกจากนี้ยังสามารถกำหนดโฟลเดอร์ที่ใช้งาน
บ่อยให้เป็น “รายการโปรด (Favorites)” ได้
โดยให้ค้นหาโฟลเดอร์ที่ต้องการในแผง
Browser แล้วคลิกขวาที่โฟลเดอร์นั้น จากนั้น
เลือก Add as a Favoriteโฟลเดอร์ดังกล่าว
จะปรากฏอยู่ในหมวด Favorites เพื่อให้เข้าถึง
ได้ง่ายในภายหลัง

2. แถบเครื่องมือ
ชุดเครื่องมือที่คุณใช้งานบ่อยที่สุดสามารถจัด
เรียงให้อยู่ในแถบเครื่องมือ (toolbar) เพื่อให้
เข้าถึงได้อย่างรวดเร็ว ตัวอย่างเช่น แถบ
เครื่องมือ *Project* ช่วยให้คุณสามารถ
บันทึก โหลด พิมพ์ และเริ่มโปรเจกต์ใหม่ได้
อย่างสะดวก สามารถปรับแต่งอินเทอร์เฟซให้
แสดงเฉพาะเครื่องมือที่คุณใช้งานบ่อย โดย
สามารถเพิ่มหรือลบแถบเครื่องมือได้ผ่านเมนู
*View ► Toolbars* 

แม้ว่าเครื่องมือบางอย่างจะไม่แสดงใน
แถบเครื่องมือ แต่คุณยังสามารถเข้า
ถึงเครื่องมือเหล่านั้นได้ผ่านเมนูต่าง ๆ
ตัวอย่างเช่น หากคุณลบแถบเครื่องมือ
*Project* (ซึ่งมีปุ่ม Save) ออกไป
คุณยังคงสามารถบันทึกแผนที่ได้โดย
คลิกที่เมนู *Project* แล้วเลือก
*Save*

3.พื้นที่แสดงแผนที่
 บริเวณนี้คือที่ที่แผนที่จะแสดงผลและ
เป็นที่ที่เลเยอร์ถูกโหลดเข้ามา ใน
หน้าต่างแผนที่ (Map Canvas) คุณ
สามารถโต้ตอบกับเลเยอร์ที่มองเห็นได้
เช่น ซูมเข้า/ออก เลื่อนแผนที่ เลือก
ข้อมูลเชิงพื้นที่ และทำงานอื่น ๆ อีก
มากมาย 

4.แถบสถานะ
 แถบนี้แสดงข้อมูลเกี่ยวกับแผนที่
ปัจจุบัน นอกจากนี้ยังสามารถใช้ปรับ
ขนาดมาตราส่วนของแผนที่ หมุน
แผนที่ และแสดงพิกัดของเคอร์เซอร์
เมาส์บนแผนที่ได้อีกด้วย

5.แถบเครื่องมือด้านข้าง
 โดยค่าเริ่มต้น แถบเครื่องมือด้านข้าง
จะมีปุ่มสำหรับโหลดเลเยอร์ และปุ่ม
ทั้งหมดสำหรับสร้างเลเยอร์ใหม่ แต่
คุณสามารถย้ายตำแหน่งแถบเครื่อง
มือทั้งหมดไปยังตำแหน่งที่คุณสะดวก
ใช้งานมากที่สุดได้ตามต้องการ

6.แถบค้นหา
 ภายในแถบนี้ คุณสามารถเข้าถึงวัตถุ
เกือบทั้งหมดใน QGIS ได้ เช่น เลเยอร์
ข้อมูลภายในเลเยอร์ อัลกอริธึมต่าง ๆ
บุ๊กมาร์กเชิงพื้นที่ ฯลฯ คุณสามารถดู
ตัวเลือกทั้งหมดได้ในส่วน Locator
settings ของคู่มือผู้ใช้ QGIS

____
สามารถสืบค้นข้อมูลเพิ่มเติมสำหรับการ
ฝึกหดและเรียนรู้ ด้วยตนเองได้ที่ 
https://docs.qgis.org/3.40/en/docs
/training_manual/index.html



เมื่อได้ทำความคุ้นเคยกับซอฟต์แวร์ในเบื้องต้นแล้ว ขอแนะนำขั้นตอนและแนวทางการ
จัดทำแผนที่โดยใช้ระบบสารสนเทศภูมิศาสตร์ (GIS) ซึ่งสามารถนำไปใช้ทงในเชิงวิชาการ
การอนุรักษ์ หรือการนำเสนอข้อมูลต่อสาธารณะ มีรายละเอียดดังนี้

📌เตรียมข้อมูลเชิงพื้นที่ (Spatial Data)
ข้อมูลแรสเตอร์ คือ ข้อมูลภาพ แผนที่ แบบจำลองความสูงเชิงตัวเลข (Digital
Elevation Model: DEM) ใช้แสดงลักษณะพื้นผิวของภูมิประเทศ โดยปกติสร้างขึ้น
จากข้อมูล ความสูง เป็นชั้นข้อมูล   แรสเตอร์ซึ่งแต่ละเซลล์มีค่าความสูงของภูมิประเทศ
ที่เสมือนปราศจากสิ่งปกคลุมทางกายภาพของผิวโลก มักนำไปใช้ในการปรับแก้ข้อมูล
เชิงเรขาคณิต หรือ ความคลาดเคลื่อนเชิงตำแหน่ง เพื่อสร้างภาพถ่ายออร์โท (สำนักงาน
พัฒนาเทคโนโลยีอวกาศและภูมิสารสนเทศ, 2561) ไฟล์แรสเตอร์ที่ใช้กับ GIS เช่น
GeoTIFF, jpeg, png เป็นต้น 

ข้อมูลเวกเตอร์ คือ ข้อมูลแบบเชิงเส้นเป็นข้อมูลที่ใช้ค่าพิกัด UTM X/Y หรือค่าละติจูด/
ลองจิจูด เพื่อกำหนดตำแหน่งของจุด เส้น และรูปหลายเหลี่ยม เช่น เส้นทาง พื้นที่ จุด
พิกัดแหล่งศิลปะบนหิน เป็นต้น บันทึกให้อยู่ในรูปแบบที่ใช้กับ QGIS เช่น: CSV (มีฟิลด์
Latitude, Longitude), Shapefile (.shp) สำหรับใช้งานกับ QGIS/ArcGIS, KML
สำหรับใช้บนเว็บหรือ Google Earth เป็นต้น

การสร้างไฟล์แรสเตอร์ SRTM DEM ในรูปแบบ TIFF
คุณจะต้องใช้ภาพราสเตอร์ (SRTM DEM) ที่ครอบคลุมพื้นที่ที่คุณเลือกในการ
สำรวจหรือพื้นที่ศึกษา 
CGIAR-CSI มีข้อมูล SRTM DEM ที่คุณสามารถดาวน์โหลดได้จากเว็บไซต์
https://srtm.csi.cgiar.org/srtmdata/
คุณจะต้องเลือกภาพที่ครอบคลุมพื้นที่ทั้ งหมดที่คุณต้องการใช้งาน ในโปรแกรม
QGIS ให้ซูมไปยังชั้นข้อมูลที่ใหญ่ที่สุดโดยใช้คำสั่ง Zoom to Layer จากนั้นดูค่า
พิกัดของขอบเขตในกล่อง Extents บริเวณแถบสถานะ 
ให้เลือกรูปแบบ GeoTIFFและเมื่อคุณกรอกข้อมูลในฟอร์มเรียบร้อยแล้ว ให้คลิกปุ่ม
Click here to Begin Search >> เพื่อค้นหาและดาวน์โหลดไฟล์ 
หลังจากที่คุณดาวน์โหลดไฟล์ที่ต้องการแล้ว ให้นำไปเก็บไว้ในโฟลเดอร์ ภายใต้
โฟลเดอร์ย่อย raster/SRTM
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🗺️ขั้นตอนการทำแผนที่

https://srtm.csi.cgiar.org/srtmdata/
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🔻ขั้นตอนที่ 1: ดาวน์โหลด SRTM DEM จากเว็บไซต์ CGIAR-CSI

✅ 1. ไปที่เว็บไซต์:👉 https://srtm.csi.cgiar.org/srtmdata/
✅ 2. เลือกพื้นที่ที่ต้องการในหน้าต่างแผนที่แล้วคลิกรูปสี่เหลี่ยมบริเวณที่ต้องการจะ
กลายเป็นสีเหลือง แล้วคลิก Search

https://srtm.csi.cgiar.org/srtmdata/
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🔻ขั้นตอนที่ 1: ดาวน์โหลด SRTM DEM จากเว็บไซต์ CGIAR-CSI

✅ 3. เข้าสู่หน้า Download ให้เลือกพื้นที่ที่ต้องการ แล้วคลิก Download SRTM
✅ 4. จะได้ไฟล์ RAR ดาวโหลดลงในคอมพิวเตอร์ ให้ทำการเปิดไฟล์โดย winRAR บันทึก
ไฟล์ไว้ในโฟลเดอร์ที่ต้องการ เช่น โฟลเดอร์ raster/SRTM/
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🗺️ขั้นตอนที่ 2: นำเข้า SRTM DEM เข้าสู่ QGIS

✅ 1. เปิด QGIS
✅ 2. ไปที่เมนู Layer > Add Layer > Add Raster Layer...
✅ 3. คลิก "..."(1) เพื่อเรียกดูไฟล์ เลือกไฟล์ .tif(2) ที่คุณดาวน์โหลด คลิก open (3)
✅ 4. คลิก Add (4) และ คลิก Close (5)
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🗺️ขั้นตอนที่ 2: นำเข้า SRTM DEM เข้าสู่ QGIS

แค่นี้ก็เสร็จแล้ว! QGIS จะโหลดแผนที่ภูมประเทศ (DEM) ของพื้นที่นั้ นให้ใช้งานต่อในการ
ทำภาพแรเงาภูมิประเทศ (Hillshade) และ เส้นชั้นความสูง (Contour line) ต่อไป
ลองซูมเข้าซูมออกในพื้นที่ต้องการ หรือปรับแต่งความเข้มของสีได้ตามต้องการ (ความ
เข้มของสีแสดงตามระดับความสูงของพื้นที่)



ที่มา: https://landscapearchaeology.org/2020/hillshade/
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🛠️ขั้นตอนที่ 3: การทำ Hillshade จาก DEM ใน QGIS

🧭 Hillshade คืออะไร?

Hillshade คือ การสร้างภาพแรเงาภูมประเทศตามแสงแดดจำลอง เพื่อให้แผนที่
ภูมิประเทศดูมีมิติเห็นความสูง-ต่ำชัดเจนขึ้น สำหรับการวิเคราะห์ภูมิประเทศเบื้องต้น

DEM HILLSHADE
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🛠️ขั้นตอนที่ 3: การทำ Hillshade จาก DEM ใน QGIS

✅ 1. เปิดไฟล์ DEM (GeoTIFF)
ถ้ายังไม่ได้เปิด:

ไปที่เมนู Layer > Add Layer > Add Raster Layer…
เลือกไฟล์ .tif ที่เป็น DEM ที่โหลดไว้ แล้วคลิก Add

✅ 2. สร้าง Hillshade
ไปที่เมนู Raster > Analysis > Hillshade
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🛠️ขั้นตอนที่ 3: การทำ Hillshade จาก DEM ใน QGIS

ในหน้าต่าง Hillshade Parameters:
          - Input layer: เลือกไฟล์ DEM ที่คุณเปิดไว้
          - Z factor (1): ปกติใช้ 1 (แต่ถ้าใช้หน่วยพิกัดเป็นองศา เช่น EPSG:4326 แนะนำ  
             ใส่ประมาณ 0.00002 เพื่อปรับความสูงให้เหมาะกับหน่วยพิกัดและได้ภาพที่
             สวยงาม) 
          - Azimuth (แสงจากทิศไหน): ค่าเริ่มต้น 315° (ทิศตะวันตกเฉียงเหนือ)
          - Altitude (ความสูงของแสง): ค่าเริ่มต้น 45° 
          - Hillshade คลิก “...” (2) เพื่อบันทึกและเลือกที่จัดเก็บ Output layer
          - ตั้งชื่อไฟล์ คลิก SAVE (3) แล้วคลิก RUN (4) รอครบ 100% แล้ว Close (5)
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🛠️ขั้นตอนที่ 3: การทำ Hillshade จาก DEM ใน QGIS

✅ 3. แสดงผล Hillshade
 ตอนนี้ QGIS จะโหลดเลเยอร์ Hillshade อัตโนมัติ เป็นภาพแรเงาเทา ๆ สวยงาม
หากต้องการให้ดูสมจริงยิ่งขึ้น:

          - คลิกขวาที่ Hillshade layer → Properties ไปที่ Symbology
          - ตั้ง Contrast enhancement เป็น Stretch to MinMax ปรับ Gamma=1.5
          - Resampling: Zoomed: in ปรับจาก Nearest neighboor เป็น billinear    
             หรือ cubic คลิก OK



✅ 4. แสดงผล Hillshade ซ้อนทับ DEM
ลองเปิด DEM และ Hillshade ซ้อนกันแบบ blending (ตั้ง Layer
Transparency=50%)
ปรับสี DEM ใน Layer Properties-Symbology-Render type ปรับเป็น
Singleband pseudocolor เลือกสีต้องการที่ Color ramp คลิก Ok จะได้ทั้ง
ข้อมูลและภาพสีสวย
ความเข้มของสีหมายถึงระดับความสูงของพื้นที่ตามที่เราปรับตั้งค่า เช่น สีอ่อนไปเข้ม
หมายถึง ความสูงจากระดับต่ำไปสูง เป็นต้น
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🛠️ขั้นตอนที่ 3: การทำ Hillshade จาก DEM ใน QGIS



🗺️ Contour Lines คืออะไร?
Contour lines หรือ เส้นชั้นความสูง คือ เส้นที่ลากบนแผนที่เพื่อต่อจุดที่มีระดับ
ความสูงเท่ากันเข้าด้วยกันเปรียบได้กับการ "ตัดเค้กภูเขาเป็นชั้น ๆ แล้วมองจากด้าน
บน" คุณจะเห็นเส้นวง ๆ ที่บอกว่าบริเวณนั้นสูงแค่ไหน ใช้สำหรับวิเคราะห์ภูมิประเทศ
และวางแผนการเดินทาง เช่น หาทางเดินเลี่ยงทางชัน เป็นต้น 

📌คุณสมบัติสำคัญของ Contour Lines:
          - เส้นที่อยู่ ใกล้กันมาก = พื้นที่นั้ น ชัน
          - เส้นที่อยู่ ห่างกัน = พื้นที่นั้ น ค่อย ๆ ลาด
          - เส้นที่เป็นวงปิด เล็กลงเรื่อย ๆ = ยอดเขา
          - ถ้าเส้นวงปิดมี ขีดเล็ก ๆ ชี้เข้าด้านใน = เป็นแอ่งหรือหลุม
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🛠️ขั้นตอนที่ 4: การทำ Contour Lines จาก DEM ใน QGIS

ที่มา: https://atlas.co/blog/what-is-a-contour-map-how-to-create-it/



🗺️สร้าง Contour Lines จาก DEM ใน QGIS
✅ 1. เตรียม DEM (GeoTIFF)
          - เปิดไฟล์ DEM ของคุณไว้ใน QGIS แล้วก่อนเริ่ม (ถ้ายังไม่มี เปิดด้วยเมนู Layer
> Add Raster Layer)
✅ 2. ไปที่เครื่องมือ Contour
          - ไปที่เมนู Raster > Extraction > Contour...
✅ 3. ตั้งค่าต่าง ๆ ดังนี้:
          - Input layer: เลือกไฟล์ DEM ที่คุณโหลดไว้ (1)
          - Interval between contour lines (2): ความห่างของเส้นชั้นความสูง เช่น 10
หมายถึง สร้างเส้นทุก ๆ 10 เมตร (แนะนำให้ใส่ 20 จะเหมาะสมสวยงาม)
          - Attribute name: พิมพ์ ELEV (3) (ไว้เก็บค่าความสูงของแต่ละเส้น)
          - เลือกบันทึก output file (ดูหน้าถัดไป) หรือปล่อยให้เป็น temporary ก็ได้ คลิก
Run รอครบ 100% แล้ว Close (5)
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🛠️ขั้นตอนที่ 4: การทำ Contour Lines จาก DEM ใน QGIS



          - หากต้องการบันทึกไฟล์ ให้คลิก “...” (1) ตรงแถบ Contours
          - ตั้งชื่อไฟล์ (2) คลิก SAVE (3) แล้วคลิก RUN (4) 
          - รอครบ 100% แล้ว Close (5)
          - เราก็จะได้ Shapefile เส้นชั้นความสูงตามที่ตองการ
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🛠️ขั้นตอนที่ 4: การทำ Contour Lines จาก DEM ใน QGIS



✅ 4. ปรับแต่งการแสดงผล
Contour จะปรากฏเป็น Vector line
คลิกขวาที่เลเยอร์ Contour →Properties

         - ไปที่ Symbology → ตั้งสี/ความหนาเส้นได้
         - ไปที่ Labels (1) → เลือก "Single Labels" (2)

เลือก Value (3): ELEV
ตั้งค่าให้แสดงค่าความสูงบนเส้น
คลิก OK (4)
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🛠️ขั้นตอนที่ 4: การทำ Contour Lines จาก DEM ใน QGIS



💡เคล็ดลับเพิ่มเติม
ถ้าเส้นดูแน่นเกินไป: ลองเพิ่ม interval เป็น 50 หรือ 100
อยากให้สวยขึ้นอีก: ซ้อน Contour ทับ Hillshade แล้วใส่ค่าความโปร่งใสก็จะดูดีมาก
เมื่อเสร็จสิ้นขั้นตอนการสร้างข้อมูลแรสเตอร์เรียบร้อย เราก็จะได้แผนที่สวย ๆ สำหรับ
เพิ่มข้อมูลเวกเตอร์ เช่น ถนน แม่น้ำ ตำแหน่งแหล่งศิลปะบนหิน หรือข้อมูลอื่นต่อไป 

                               ขอขอบคุณข้อมูลเวกเตอร์ จาก มิตรเอิร์ธ
                               https://www.mitrearth.org/category/map/
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🛠️ขั้นตอนที่ 4: การทำ Contour Lines จาก DEM ใน QGIS



การเตรียมข้อมูลเวกเตอร์ในรูปแบบไฟล์ CSV 

การสร้างไฟล์ข้อมูลเวกเตอร์สำหรับนำเข้าจุดพิกัดของแหล่ง (Point Vector) ลงใน
QGIS โดยใช้ Microsoft Excel มีขั้นตอนง่าย ๆ แบบ Step-by-Step ดังนี้:

✅ ขั้นตอนการเตรียมไฟล์ CSV ใน Excel
1. เปิด Excel แล้วสร้างตารางข้อมูลที่ประกอบด้วย ลำดับ ชื่อแหล่ง และค่าพิกัด ใช้ชื่อ
คอลัมน์ว่า latitude (LAT) และ longitude (LONG) หรือ X, Y เพื่อให้ QGIS อ่านค่า
พิกัดได้ ตัวอย่าง เช่น:

2. ตรวจสอบข้อมูล: 
          - ตรวจสอบให้แน่ใจว่า ไม่มีช่องว่าง หรือ เครื่องหมายพิเศษ
          - พิกัดควรเป็น ค่าทศนิยม (Decimal degrees) เช่น 14.2310, 
          ไม่ใช่ค่าองศา 14° 23′ 10″
3. บันทึกเป็นไฟล์ CSV
         - ไปที่ File > Save As
         - เลือกชนิดไฟล์เป็น ➤ CSV UTF-8 (Comma delimited) *.csv
         - ตั้งชื่อไฟล์ เช่น location_points.csv
         - คลิก Save
💡 แนะนำให้เลือก “CSV UTF-8” หรือ TIS620 เพื่อรองรับการแสดงผลเป็นภาษาไทย   
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🛠️ขั้นตอนที่ 5: การนำเข้าข้อมูลเวกเตอร์ ใน QGIS



🧭วิธีนำเข้าข้อมูลเวกเตอร์ใน QGIS มี 3 วิธี
✅ วิธีที่ 1: ใช้เมนู "Add Vector Layer" สำหรับ Shapefile

เปิด QGIS
ไปที่เมนู Layer > Add Layer > Add Vector Layer...
ในช่อง Source Type: เลือก File (ถ้าเป็นไฟล์ shapefile, GeoJSON ฯลฯ)
คลิก "..." เลือกไฟล์เวกเตอร์ที่ต้องการ 
คลิก open
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คลิก Add แล้ว Close 🎉 เสร็จแล้ว! ข้อมูลจะปรากฏในแผนที่ของคุณทันที
ไฟล์ที่เลือกจะแสดงในแถบ Layers

36

🛠️ขั้นตอนที่ 5: การนำเข้าข้อมูลเวกเตอร์ ใน QGIS



✅ วิธีที่ 2: Drag & Drop
แค่ลากไฟล์ .shp, .geojson, .kml เข้ามาในหน้าต่าง QGIS ก็ได้เลย ง่ายมาก!

✅ วิธีที่ 3: นำเข้า CSV 
ไปที่ Layer > Add Layer > Add Delimited Text Layer
ตรงแถบ File name คลิกที่ “...” เลือกไฟล์ .csv กด Open
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แถบ Geometry Definition เลือกคอลัมน์ที่เป็นพิกัด X (Longitudes), Y
(Latitude)
ตั้ง CRS (Coordinate Reference System) ให้ถูกต้อง เช่น EPSG:4326
(WGS 84)
คลิก Addแล้ว Close จะปรากฏจุดพิกัดตำแหน่งตามตารางข้อมูลที่เราสร้างไว้
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ฟอร์ม (Form) ใน QGIS มีประโยชน์มากสำหรับการป้อนหรือแก้ไขข้อมูลเชิงคุณภาพใน
แผนที่ เช่น การกรอกข้อมูลของแหล่งโบราณคดี จุดที่น่าสนใจ (point of interests:
POI) จุดสำรวจในภาคสนาม เป็นต้น ซึ่งสามารถทำได้ผ่าน Attribute Form ของเลเยอร์
เวกเตอร์ โดยไม่ต้องเขียนโค้ดเลยก็ได้ หรือถ้าต้องการขั้นสูง ก็สามารถใช้ Python
(PyQGIS) ได้อีกด้วย 

การสร้างฟอร์มสำรวจแหล่งโบราณคดี มีขั้นตอนง่าย ๆ 2 ขั้นตอน ได้แก่ การเพิ่ม Field
และการสร้าง Form เริ่มจากการสร้างไฟล์เวกเตอร์ เช่น CSV, SHP เป็นต้น จากนั้น
ทำการเพิ่ม Field (Attribute) ใหม่ ซึ่งเป็นขั้นตอนพื้นฐานที่ใช้เพื่อเพิ่มข้อมูลให้กับ
เลเยอร์เวกเตอร์ เช่น ข้อมูลที่ตั้ ง ประเภทของแหล่ง ขนาดของแหล่ง เป็นต้น แล้วทำการ
ปรับแต่งฟิลด์ข้อมูลให้เหมาะสมใน Attribute Form มีรายละเอียด ดังนี้

🪜ขั้นตอนการเพิ่ม Field ใน QGIS
โหลดเลเยอร์เวกเตอร์ เข้ามาใน QGIS (เช่น Shapefile, GeoPackage, หรือ
PostGIS)
คลิกขวาที่เลเยอร์นั้น → เลือก “Open Attribute Table” หรือดับเบิลคลิกเพื่อ
เข้าไปที่ Properties
ที่แถบเมนูด้านบนของ Attribute Table →คลิกไอคอน “Toggle Editing Mode”
(รูปดินสอ ✏️) เพื่อเปิดโหมดแก้ไข
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คลิกไอคอน “New Field” (รูปตาราง + เครื่องหมายบวก ➕)
กำหนดรายละเอียดของฟิลด์ใหม่:

          Name: ชื่อฟิลด์ (เช่น note, area_type)
          Type: ประเภทข้อมูล ได้แก่ ข้อความ=Text (string), จำนวนเต็ม=Whole
number (integer), เลขฐานสิบ=Decimal number (float), วันที่=Date
          Length / Precision (ถ้ามี)

กด OK เพื่อเพิ่ม Field จะปรากฏใน Attribute Table
เมื่อเพิ่มเสร็จ อย่าลืม กด Save Edits (ไอคอนแผ่นดิสก์ 💾) และ รูปดินสอ ✏️
เพื่อปิดโหมดแก้ไข
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🧭ขั้นตอนการสร้างฟอร์มใน QGIS 
เปิด QGIS และสร้างหรือโหลดเลเยอร์เวกเตอร์ (Vector Layer) เช่น Shapefile
หรือ GeoPackage
คลิกขวาที่เลเยอร์นั้น → เลือก “Properties”
ไปที่แท็บ “Attributes Form”
ที่นี่คุณสามารถ: เปลี่ยนลำดับของฟิลด์ ตั้งค่าประเภทของอินพุต (Widget Type)
เช่น: Text Edit – กล่องข้อความ, 

             Value Map – รายการตัวเลือกแบบ drop-down, 
             Date/Time – ช่องกรอกวันที่,
             Checkbox – ช่องติ๊ก, 

ใส่ค่าเริ่มต้น (Default values), ตั้งค่าให้เป็น Read-only, Hidden, หรือ
Required
ไปที่แท็ป Autogenerate คลิกที่ปุ่มสามเหลี่ยมชี้ลง เลือก Drag and Drop
Designer 
เมื่อตั้งค่าเสร็จแล้ว กด OK 
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แล้วลองใช้ Identify Features Tool      →คลิกจุด/พื้นที่ในเลเยอร์ → จะเห็นฟอร์ม
ที่คุณกำหนดขึ้นมา
ลองเพิ่มหรือแก้ไขจุด: คลิกเลือกไฟล์เวกเตอร์→คลิกที่รูปดินสอ ✏️ เปิดใช้งานแก้ไข
คลิก Add point feature       คลิกตำแหน่งที่ต้องการ กรอกข้อมูล กด OK 
หากต้องการย้ายหรือลบจุด: คลิก Vector tool         คลิกเลือกจุดที่ต้องการแล้ว
คลิกตำแหน่งที่ต้องการเพื่อย้ายจุด หรือ กดปุ่ม Delete เพื่อลบจุด 
เสร็จแล้ว! อย่าลืมกดบันทึก         และกดรูปดินสอ ✏️เพื่อปิดใช้งานแก้ไข
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🛠️ตัวอย่างฟอร์มสำรวจแหล่งศิลปะบนหิน 

 เมื่อสร้างฟอร์มเรียบร้อยแล้ว เราสามารถที่จะพิมพ์ออกมาสหรับเก็บข้อมูลภาค
สนามได้ครบถ้วน มีความเป็นระเบียบ
ช่วยในการจัดการข้อมูลหลังจากงานภาคสนามไดง่ายและสะดวกรวดเร็วยิ่งขึ้น

💡 แนะนำให้พิมพ์แบบฟอร์มใน 1 หน้ากระดาษ เพื่อสะดวกในการเก็บข้อมูลในภาคสนาม
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